Follow

Updated a PHP lib I publish. Set minimum PHP version to 7.1. Got complaints.

"I'm on 5.6! Why'd you break my site?!?"

Wasn't my fault. I warned you. In the readme. In the configuration. In a massive warning screen printed on your site.

"OK, fine, I upgraded Debian. Now I have PHP 7.0. But things are still broken!!!"

I know. Minimum is 7.1. That's not 7.0.

"Is this even necessary?!"

Yep. You're paying exactly $0 for this tool. Unless that changes, I define the acceptance criteria.

Sign in to participate in the conversation
Mastodon

Invite-only community of developers, builders, makers, and tektons.